Slideshow and module by 888 poker review
Welcome, Guest
Username Password: Remember me

Installing Metasploit
(1 viewing) (1) Guest

TOPIC: Installing Metasploit

Re: Installing Metasploit 4 years, 9 months ago #1801

Got Metasploit installed, but not quite running. Basically just installed all packages with mention of Ruby and the Python packages outlined by the link in my previous post.
If you type "msfconsole" then it maxes out the physical RAM, CPU usage bounces and I didn't see more than 19mb of swap being used (out of 511mb)
Sometimes the router restarts, sometimes it doesn't.
"strace msfconsole" reveals that it is indeed working very hard, but it isn't very revealing.
Due to my non-existent knowledge of Ruby, I cannot comment any further
Will keep trying, though.

EDIT: Tried the 2.5 framework which supposedly worked, produced identical results. Just sits there...
Last Edit: 4 years, 9 months ago by megal0maniac.

Re: Installing Metasploit 4 years, 8 months ago #1810

  • bongk
  • OFFLINE
  • Administrator
  • Posts: 121
  • Karma: 10
Wow awesome that you got that far, though.

Re: Installing Metasploit 4 years, 8 months ago #1813

Only secret is having a massive (1gb) sys partition
The rest is just opkg install and copy-paste.
I was a bit stupid though. When testing 2.5, I just ran "msfconsole" and not "./msfconsole"
Because I put the latest version in /usr/bin, it didn't look in the cwd.
Having figured this out, it doesn't work. Dies with an error, and won't run. (Some problem with the Ruby script)

When I get the time, I'll dump the strace output and try to figure out why it fails to actually start.
Last Edit: 4 years, 8 months ago by megal0maniac.

Re: Installing Metasploit 4 years, 4 months ago #1879

  • PunchBag
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
  • Karma: 0
I've been trying to get this working for a while now, and I would agree that it seems to be Ruby related. It doesn't help that the Ruby packages in the default repository seem to be broken by default. I found packages for Ruby 1.9.3 located at:

docs.google.com/file/d/0B54xzz44RpW6Ylpa...QVk/edit?usp=sharing

I installed these, and it seemed better, but when I go to update/install Ruby Gems, the whole thing seems to fall down. Having delved a little deeper, it seems to me that some of the gems also require compilation prior to being installed, and the wr-703n isn't capable of doing that.

Re: Installing Metasploit 4 years, 4 months ago #1880

Ah!
I think it lives!
root@Wrtstar:/usr/lib/ruby/1.9/rubygems# /home/msf/msfex
[*] Loading the Metasploit Framework base ...
[*] Initializing a Framework instance...
[*] Initializing modules ...
[-] Please specify a module to run!
root@Wrtstar:/usr/lib/ruby/1.9/rubygems#


Will update when I have more info. Also, this is on a Seagate Dockstar (1.2ghz CPU with 128mb RAM)
Ruby is quite heavy, but doesn't mean it won't run on the WR703N!
If this works properly, then next step is the router.
I'm just worried about hardware resources...

For those who are feeling brave...

opkg install ruby ruby-cgi ruby-core ruby-dl ruby-enc ruby-erb ruby-gdbm ruby-gems ruby-irb ruby-json ruby-ncurses ruby-nkf ruby-openssl ruby-rake ruby-rdoc ruby-readline ruby-rexml ruby-rss ruby-unit ruby-webrick ruby-xmlrpc ruby-yaml ruby-zlib

Fix socket.so according to forum.openwrt.org/viewtopic.php?pid=208463#p208463
gem update --system
gem install activesupport
gem install activesupport-inflector


This is preliminary and I'm not sure if it works because I typed it mostly from memory. One thing I do know is that you'll need patience. Even with the Dockstar, I have to wait quite a bit for anything to happen. Let me know how it goes
Last Edit: 4 years, 4 months ago by megal0maniac. Reason: More detail and instruction
The following user(s) said Thank You: PunchBag

Re: Installing Metasploit 4 years, 4 months ago #1881

  • PunchBag
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
  • Karma: 0
Excellent!

Out of interest, is that on a trunk build, or on 12.09? I have ordered an upgraded 703n from China - just waiting for it to arrive, so if it doesn't work on stock, then I can try to see if it works on one with more RAM.
Time to create page: 0.21 seconds
2011. © 2014 Kevin Bong / Michael Vieau
Auto Insurance Quotes