Slideshow and module by 888 poker review
Welcome, Guest
Username Password: Remember me

Karma not working
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: Karma not working

Karma not working 5 years, 10 months ago #25

  • bongk
  • OFFLINE
  • Administrator
  • Posts: 121
  • Karma: 10
FYI for everyone, Karma installed OK but does not work at this time.
Kismet and the Aircrack suite seem to work fine.

Here are the steps I used to get kismet_server working:

Sorry for the delay, I think I just got it figured out.
I was able to duplicate your issue.
I think the issue is that either your WiFi interface is not in Monitor Mode before you start kismet_server, or kismet is trying to write its logfiles to the internal flash and not the USB drive.

Here is what I did and the problem was fixed:
1. mkdir /mnt/usb/kismetlogs
2. Edit /etc/kismet/kismet.conf
-- Uncomment and set logprefix=/mnt/usb/kismetlog/
-- Uncomment and set ncsource=wlan0
-- Change to gps=false

3. Set eth0 to DHCP and set the wifi interface to monitor mode. SSH into the eth0 interface.

4. Check that the Wifi interface is in monitor mode using iwconfig
5. launch kismet_server

kismet_server runs and logs to /mnt/usb/kismetlogs without hanging.
Last Edit: 5 years, 10 months ago by bongk.

Re: Karma not working 5 years, 10 months ago #38

  • HyJynx
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
  • Karma: 0
Please keep me updated if you do manage to get karama working.

Re: Karma not working 5 years, 10 months ago #41

I'm working on compiling the modified hostapd that is supposed to work without all the ruby, etc. issues involved. I'm really new with the OpenWRT platform so it will probably take me a day or two to be sure I'm doing everything correctly but so far I'm at least progressing.

Re: Karma not working 5 years, 10 months ago #49

Update: I have successfully compiled the modified hostapd and I've seen it spit out the appropriate info when I run it with the "-v" option but I still have to setup wireless again and see if the nl80211 driver will install since I'm running on a default openwrt install right now(I had to reflash about 10 times in a day thanks to me goofing something up while testing...I'm used to it at this point..heh).

Anyway, if anyone has any experience in working with the OpenWRT dev platform and would like to help me get this thing properly integrated, I'll be happy to provide a working package, etc. once this is complete.
  • Page:
  • 1
Time to create page: 0.17 seconds
2011. © 2014 Kevin Bong / Michael Vieau
Auto Insurance Quotes